Re: [PATCH -v2 6/7] x86, NMI, Add support to notify hardware errorwith unknown NMI

From: Huang Ying
Date: Mon Sep 27 2010 - 20:36:21 EST


On Mon, 2010-09-27 at 23:20 +0800, Don Zickus wrote:
> On Mon, Sep 27, 2010 at 03:38:16PM +0200, Robert Richter wrote:
> > On 27.09.10 08:47:53, huang ying wrote:
> >
> > > I think explicit function calls have better readability than notifier chains.
> >
> > What is different to unknown_nmi() then?
> >
> > So no, in your case you want to catch unknown nmis for a certain
> > hardware and then throw a panic. This should be clearly implemented in
> > a separate handler for this piece of hardware.
> >
> > We want to cleanup this code and throw out all hardware specific
> > snippets, and not introduce new special cases here.
>
> I tend to agree with Robert here. I don't know if there were any 'rules'
> to which handlers get directly called versus ones that go through the
> die_chain, so I was originally going to let it go. But if they aren't
> any, it does look cleaner to have everything in die_chains.

Personally, I think directly call has better readability than
notifier_chain in general. Notifier_chain is for:

- Call functions in module.
- Need to enable/disable (via register/unregister) at run time.
- Call functions from low layer to high layer.

Otherwise, notifier_chain should be avoid if possible. So I think it is
better to keep direct call as much as possible.

Best Regards,
Huang Ying

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/