[PATCH 0/5] x86, NMI: give NMI handler a face-lift

From: Don Zickus
Date: Fri Oct 15 2010 - 22:23:11 EST


Restructuring the nmi handler to be more readable and simpler.

This is just laying the ground work for future improvements in this area.

I know people were complaining about having DIE_NMI and DIE_NMI_IPI, but
for now it is consistent with what was there before. Hopefully, we can
modify the notifier chain to make it smarter and combine the two events.

I also left out one of Huang's patch until we figure out how we are going
to proceed with a new notifier.

Tested 32-bit and 64-bit on AMD and Intel machines.

Cheers,
Don

Huang Ying (5):
x86, NMI: Add NMI symbol constants and rename memory parity to PCI
SERR
x86, NMI: Add touch_nmi_watchdog to io_check_error delay
x86, NMI: Rewrite NMI handler
x86, NMI: Allow NMI reason io port (0x61) to be processed on any CPU
x86, NMI: Remove do_nmi_callback logic

arch/x86/include/asm/mach_traps.h | 12 +++-
arch/x86/include/asm/nmi.h | 10 +++-
arch/x86/kernel/apic/hw_nmi.c | 1 -
arch/x86/kernel/apic/nmi.c | 29 +-------
arch/x86/kernel/cpu/perf_event.c | 1 -
arch/x86/kernel/traps.c | 141 ++++++++++++++++++++----------------
arch/x86/oprofile/nmi_int.c | 1 -
arch/x86/oprofile/nmi_timer_int.c | 2 +-
drivers/char/ipmi/ipmi_watchdog.c | 2 +-
drivers/watchdog/hpwdt.c | 2 +-
10 files changed, 102 insertions(+), 99 deletions(-)

--
1.7.2.3

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/