Re: [PATCH] n_hdlc fix read and write locking

From: Arnd Bergmann
Date: Tue Oct 26 2010 - 06:41:15 EST


On Tuesday 26 October 2010, Paul Fulghum wrote:
> On 10/25/2010 3:31 PM, Arnd Bergmann wrote:
>
> > Would it be possible to express the same using
> > wait_event_interruptible()?
>
> Yes if I embed an assignment in the event expression:
>
> rc = wait_event_interruptible(&wait, (buf = get_buf()));
> if (!rc)
> process_buf(buf);
>
> Is that considered acceptable?

I'd do it if it makes the code more readable. We need the patch
for the stable release, so it really should be obvious not to
introduce new bugs. I could not fully understand the version
you posted, so if you can make it easier to understand by using
wait_event, please do so. If you think that putting the
assignment into the macro argument outweighs the advantage from
the wait_event, just keep your version.

Arnd
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/