Re: [PATCH] rcu_read_lock/unlock protect find_task_by_vpid call

From: Sergey Senozhatsky
Date: Sat Oct 30 2010 - 05:32:47 EST


On (10/29/10 13:16), Paul E. McKenney wrote:
> On Fri, Oct 29, 2010 at 03:55:50PM +0300, Sergey Senozhatsky wrote:
> > Commit 4221a9918e38b7494cee341dda7b7b4bb8c04bde "Add RCU check for
> > find_task_by_vpid()" introduced rcu_lockdep_assert to find_task_by_pid_ns.
> > Assertion failed in sys_ioprio_get. The patch is fixing assertion
> > failure in ioprio_set as well.
> >
> > ===================================================
> > [ INFO: suspicious rcu_dereference_check() usage. ]
> > ---------------------------------------------------
> > kernel/pid.c:419 invoked rcu_dereference_check() without protection!
> >
> > rcu_scheduler_active = 1, debug_locks = 0
> > 1 lock held by iotop/4254:
> > #0: (tasklist_lock){.?.?..}, at: [<ffffffff811104b4>] sys_ioprio_get+0x22/0x2da
> >
> > stack backtrace:
> > Pid: 4254, comm: iotop Not tainted
> > Call Trace:
> > [<ffffffff810656f2>] lockdep_rcu_dereference+0xaa/0xb2
> > [<ffffffff81053c67>] find_task_by_pid_ns+0x4f/0x68
> > [<ffffffff81053c9d>] find_task_by_vpid+0x1d/0x1f
> > [<ffffffff811104e2>] sys_ioprio_get+0x50/0x2da
> > [<ffffffff81002182>] system_call_fastpath+0x16/0x1b
> >
> >
> > Signed-off-by: Sergey Senozhatsky <sergey.senozhatsky@xxxxxxxxx>
> >
> > ---
> >
> > diff --git a/fs/ioprio.c b/fs/ioprio.c
> > index 748cfb9..666343d 100644
> > --- a/fs/ioprio.c
> > +++ b/fs/ioprio.c
> > @@ -113,8 +113,11 @@ SYSCALL_DEFINE3(ioprio_set, int, which, int, who, int, ioprio)
>
> Interesting...
>
> The task-list lock is read-held at this point, which should mean that
> the PID mapping cannot change. The lockdep_tasklist_lock_is_held()
> function does lockdep_is_held(&tasklist_lock), which must therefore
> only be checking for write-holding the lock. The fix would be to
> make lockdep_tasklist_lock_is_held() check for either read-holding or
> write-holding tasklist lock.
>
> Or is there some subtle reason that read-holding the tasklist lock is
> not sufficient?
>

Hello,

On the kernel/pid.c side we have the requirement that
find_task_by_vpid -> find_task_by_pid_ns

should be called with rcu_read_lock.

/*
* Must be called under rcu_read_lock().
*/
struct task_struct *find_task_by_pid_ns(pid_t nr, struct pid_namespace *ns)
{
rcu_lockdep_assert(rcu_read_lock_held());
return pid_task(find_pid_ns(nr, ns), PIDTYPE_PID);
}


Should it be changed to (let's say)

struct task_struct *find_task_by_pid_ns(pid_t nr, struct pid_namespace *ns)
{
- rcu_lockdep_assert(rcu_read_lock_held());
+ rcu_lockdep_assert(rcu_read_lock_held() || lockdep_tasklist_lock_is_held());
return pid_task(find_pid_ns(nr, ns), PIDTYPE_PID);
}


Sergey

> Thanx, Paul
>
> > case IOPRIO_WHO_PROCESS:
> > if (!who)
> > p = current;
> > - else
> > + else {
> > + rcu_read_lock();
> > p = find_task_by_vpid(who);
> > + rcu_read_unlock();
> > + }
> > if (p)
> > ret = set_task_ioprio(p, ioprio);
> > break;
> > @@ -202,8 +205,11 @@ SYSCALL_DEFINE2(ioprio_get, int, which, int, who)
> > case IOPRIO_WHO_PROCESS:
> > if (!who)
> > p = current;
> > - else
> > + else {
> > + rcu_read_lock();
> > p = find_task_by_vpid(who);
> > + rcu_read_unlock();
> > + }
> > if (p)
> > ret = get_task_ioprio(p);
> > break;
> >
> > --
> > To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> > the body of a message to majordomo@xxxxxxxxxxxxxxx
> > More majordomo info at http://vger.kernel.org/majordomo-info.html
> > Please read the FAQ at http://www.tux.org/lkml/
>

Attachment: pgp00000.pgp
Description: PGP signature