Re: [PATCH][resend][SCSI] Reduce number of sequential pointer derefsin scsi_error.c and reduce size as well

From: Linus Torvalds
Date: Thu Nov 18 2010 - 15:42:24 EST


On Thu, Nov 18, 2010 at 11:30 AM, Jesper Juhl <jj@xxxxxxxxxxxxx> wrote:
>
> This is the fourth time I send this patch. For some reason it seems unable
> to get any feedback at all. I'd really appreciate a clear ACK or NACK on
> it and I'll keep resending it until it's either merged or I get a NACK
> with a reason.

The patch looks ok to me, but you've basically selected the least
interesting file possible. No wonder people can't seem to care.

Also, this is just ugly as hell, and doesn't help anything:

+ int (*eh_abort_handler)(struct scsi_cmnd *) =
+ scmd->device->host->hostt->eh_abort_handler;

since the compiler will have optimized that double access away anyway
(no writes in between). So you could have made it about a thousand
times more readable with no downside by doing

struct scsi_host_template *hostt = scmd->device->host->hostt;

if (!hostt->eh_abort_handler)
return FAILED;
return hostt->eh_abort_handler(scmd);

instead. Look ma, no long lines.

Rule of thumb: if you need more than one line for an expression or
variable definition, you're doing something wrong.

Linus
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/