Re: [ath9k-devel] [PATCH wireless-next] ath: Rename ath_print toath_debug

From: Felix Fietkau
Date: Wed Dec 01 2010 - 09:37:57 EST


On 2010-12-01 3:27 PM, Joe Perches wrote:
> On Tue, 2010-11-30 at 23:56 -0800, Luis R. Rodriguez wrote:
>> On Tue, Nov 30, 2010 at 12:19 PM, Joe Perches <joe@xxxxxxxxxxx> wrote:
>> > Poor function naming is just that.
>> > It reduces readability and the uses are counter expectation.
>> The name is perfect, we use it to print anything, even non-debugging stuff.
>
> 'fraid not.
>
> ath/debug.h
>
> #ifdef CONFIG_ATH_DEBUG
> void ath_print(struct ath_common *common, int dbg_mask, const char *fmt, ...)
> __attribute__ ((format (printf, 3, 4)));
> #else
> static inline void __attribute__ ((format (printf, 3, 4)))
> ath_print(struct ath_common *common, int dbg_mask, const char *fmt, ...)
> {
> }
> #endif /* CONFIG_ATH_DEBUG */
Now we're getting closer to something worth fixing. IMHO we should
change the code so that ath_print(common, ATH_DBG_FATAL, ...) prints
something even with CONFIG_ATH_DEBUG unset. To get this done, some
renaming would make sense here.

- Felix
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/