Re: [PATCH 2/8] cpuidle: Rename X86 specific idle poll state[0] from C0 to CPUIDLE

From: Bjorn Helgaas
Date: Thu Dec 02 2010 - 12:31:31 EST


On Thursday, December 02, 2010 09:42:22 am Thomas Renninger wrote:
> C0 means and is well know as "not idle".
> All documentation out there uses this term as "running"/"not idle"
> state. Also Linux userspace tools (e.g. cpufreq-aperf and turbostat)
> show C0 residency which there is correct, but means something totally
> else than cpuidle "POLL" state.
>
>
> Signed-off-by: Thomas Renninger <trenn@xxxxxxx>
> CC: arjan@xxxxxxxxxxxxxxx
> CC: lenb@xxxxxxxxxx
> CC: linux-acpi@xxxxxxxxxxxxxxx
> CC: Ingo Molnar <mingo@xxxxxxx>
> CC: linux-kernel@xxxxxxxxxxxxxxx
> ---
> drivers/cpuidle/cpuidle.c | 2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/drivers/cpuidle/cpuidle.c b/drivers/cpuidle/cpuidle.c
> index 08d5f05..99cc8fc 100644
> --- a/drivers/cpuidle/cpuidle.c
> +++ b/drivers/cpuidle/cpuidle.c
> @@ -260,7 +260,7 @@ static void poll_idle_init(struct cpuidle_device *dev)
>
> cpuidle_set_statedata(state, NULL);
>
> - snprintf(state->name, CPUIDLE_NAME_LEN, "C0");
> + snprintf(state->name, CPUIDLE_NAME_LEN, "POLL");

The description says "rename C0 to CPUIDLE", but the patch looks like
"rename C0 to POLL".

> snprintf(state->desc, CPUIDLE_DESC_LEN, "CPUIDLE CORE POLL IDLE");
> state->exit_latency = 0;
> state->target_residency = 0;
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/