Re: [PATCH 1/2] kstrto*: converting strings to integers done(hopefully) right

From: Alexey Dobriyan
Date: Mon Dec 06 2010 - 10:19:56 EST


On Mon, Dec 6, 2010 at 3:26 AM, Thiago Farina <tfransosi@xxxxxxxxx> wrote:
> On Wed, Jun 9, 2010 at 6:46 PM, Alexey Dobriyan <adobriyan@xxxxxxxxx> wrote:
>> diff --git a/lib/test-kstrtox.c b/lib/test-kstrtox.c
>> new file mode 100644
>> index 0000000..56fda26
>> --- /dev/null
>> +++ b/lib/test-kstrtox.c
>> @@ -0,0 +1,356 @@
>> +#include <linux/init.h>
>> +#include <linux/kernel.h>
>> +#include <linux/module.h>
>> +
>> +#define for_each_test(i, test) \
>> +       for (i = 0; i < sizeof(test) / sizeof(test[0]); i++)
>> +
> micronit: Can you use ARRAY_SIZE macro here? Ignore this if it's irrelevant.

Dunno,
sizeof(x)/sizeof(x[0]) is really C idiom.
And ARRAY_SIZE is misnamed, it doesn't reflect size.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/