Re: [PATCH 2/2] USB: ehci: tegra: Align DMA transfers to 32 bytes

From: Greg KH
Date: Fri Dec 17 2010 - 19:41:27 EST


On Fri, Dec 17, 2010 at 03:40:08PM -0800, rmorell@xxxxxxxxxx wrote:
> On Fri, Dec 17, 2010 at 03:09:40PM -0800, Greg KH wrote:
> > On Fri, Dec 17, 2010 at 02:42:21PM -0800, rmorell@xxxxxxxxxx wrote:
> > > On Fri, Dec 17, 2010 at 02:35:02PM -0800, Greg KH wrote:
> > > > On Fri, Dec 17, 2010 at 01:58:49PM -0800, Robert Morell wrote:
> > > > > --- a/include/linux/usb.h
> > > > > +++ b/include/linux/usb.h
> > > > > @@ -975,6 +975,7 @@ extern int usb_disabled(void);
> > > > > #define URB_SETUP_MAP_SINGLE 0x00100000 /* Setup packet DMA mapped */
> > > > > #define URB_SETUP_MAP_LOCAL 0x00200000 /* HCD-local setup packet */
> > > > > #define URB_DMA_SG_COMBINED 0x00400000 /* S-G entries were combined */
> > > > > +#define URB_DRIVER_PRIVATE 0x80000000 /* For driver-private use */
> > > >
> > > > Um, what? You are using this for a build check, which seems pointless
> > > > as you already modified the code to not need this.
> > > >
> > > > So it doesn't look like this is needed, right?
> > >
> > > The intention was to reserve space in the URB flags for
> > > implementation-specific use.
> >
> > Yes, but _which_ driver are you talking about here? You didn't say that
> > this was a HCD-only flag, right?
>
> Sorry, I may not have been clear. I did mean HCD-only flag; its exact
> meaning depends on the HCD in question. In the case of tegra-ehci, it
> means that a temporary buffer has been allocated that needs freeing
> later.
>
> Would it make more sense if I called it URB_HCD_PRIVATE_MASK?

How about naming it what it is being used for?

thanks,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/