Re: [Xen-devel] [PATCH 2/3] drivers/xen/balloon.c: Various balloon features and fixes

From: Daniel Kiper
Date: Wed Dec 29 2010 - 10:04:28 EST


Hi,

On Mon, Dec 20, 2010 at 02:51:44PM +0000, Ian Campbell wrote:
> On Mon, 2010-12-20 at 13:47 +0000, Daniel Kiper wrote:
> > Features and fixes:
> > - HVM mode is supported now,
> > - migration from mod_timer() to schedule_delayed_work(),
> > - removal of driver_pages (I do not have seen any
> > references to it),
> > - protect before CPU exhaust by event/x process during
> > errors by adding some delays in scheduling next event,
> > - some other minor fixes.
>
> Each of those bullets should be a separate patch (or several if
> appropriate). I didn't review most of the rest because it mixed so much
> stuff together but a couple of minor things jumped out.

Done. I will send new patch release today.

> > -static void scrub_page(struct page *page)
> > +static inline void scrub_page(struct page *page)
>
> Is there some reason we need to override the compiler's decision here?
> There is some discussion of the (over)use of inline in CodingStyle.

Done.

> > static struct attribute_group balloon_info_group = {
> > .name = "info",
> > - .attrs = balloon_info_attrs,
> > + .attrs = balloon_info_attrs
> > };
> >
> > static struct sysdev_class balloon_sysdev_class = {
> > - .name = BALLOON_CLASS_NAME,
> > + .name = BALLOON_CLASS_NAME
> > };
>
> I don't think there is anything wrong with the existing style here.

I do not insist on applying this patch however, this notation
is more readable for me. I am not confused by
comma which suggest that next attribut follow it.

Daniel
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/