Re: [RFC patch 3/5] ftrace trace event add missing semicolumn

From: Valdis . Kletnieks
Date: Tue Jan 04 2011 - 22:01:53 EST


On Wed, 05 Jan 2011 03:08:02 +0100, Frederic Weisbecker said:
> On Tue, Jan 04, 2011 at 07:18:37PM -0500, Mathieu Desnoyers wrote:

> > > > --- linux-2.6-lttng.orig/include/trace/ftrace.h
> > > > +++ linux-2.6-lttng/include/trace/ftrace.h
> > > > @@ -69,7 +69,7 @@
> > > > #undef DEFINE_EVENT
> > > > #define DEFINE_EVENT(template, name, proto, args) \
> > > > static struct ftrace_event_call __used \
> > > > - __attribute__((__aligned__(4))) event_##name
> > > > + __attribute__((__aligned__(4))) event_##name;

> > Adding this semicolumn here ensures that all Ftrace macros are consistent wrt
> > semicolumns. We can get away without consistency currently exactly because the
> > current scheme adds many useless semicolumns between each TRACE_EVENT().

> Are you sure you want to put so much time on this?

> This will require a massive change for the sole win of removing double ";"
> in generated code. This won't optimize much the build, and it will make the things
> not so much more readable for very rare people who dare to have interest into the
> TRACE_EVENT generated code. That notwithstanding the obfuscation of that generated
> code resides more in the lack of indentation and newlines than in double
> semicolons that we barely notice.

Can DEFINE_EVENT ever be sensibly used in a context where the additional ; will
cause an issue (for instance, a hypothetical array initialization like:

static struct events[] = {DEFINE_EVENT(..), DEFINE_EVENT(...) }

or other places we usually do the 'do { X } while (0)' trick to make the code legal?

Attachment: pgp00000.pgp
Description: PGP signature