Re: [PATCH] memcg: remove charge variable in unmap_and_move

From: KAMEZAWA Hiroyuki
Date: Tue Jan 11 2011 - 01:34:07 EST


On Tue, 11 Jan 2011 15:00:50 +0900
Minchan Kim <minchan.kim@xxxxxxxxx> wrote:

> memcg charge/uncharge could be handled by mem_cgroup_[prepare/end]
> migration itself so charge local variable in unmap_and_move lost the role
> since we introduced 01b1ae63c2.
>
> In addition, the variable name is not good like below.
>
> int unmap_and_move()
> {
> charge = mem_cgroup_prepare_migration(xxx);
> ..
> BUG_ON(charge); <-- BUG if it is charged?
> ..
> uncharge:
> if (!charge) <-- why do we have to uncharge !charge?
> mem_group_end_migration(xxx);
> ..
> }
>
> So let's remove unnecessary and confusing variable.
>
> Suggested-by: Daisuke Nishimura <nishimura@xxxxxxxxxxxxxxxxx>
> Signed-off-by: Minchan Kim <minchan.kim@xxxxxxxxx>
> Cc: Balbir Singh <balbir@xxxxxxxxxxxxxxxxxx>
> Cc: KAMEZAWA Hiroyuki <kamezawa.hiroyu@xxxxxxxxxxxxxx>

Ack.

Thanks,
-Kame

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/