Re: [RFC] [PATCH 2.6.37-rc5-tip 4/20] 4: uprobes: Adding andremove a uprobe in a rb tree.

From: Srikar Dronamraju
Date: Wed Jan 26 2011 - 03:47:46 EST


* Peter Zijlstra <peterz@xxxxxxxxxxxxx> [2011-01-25 13:15:42]:

> On Thu, 2010-12-16 at 15:28 +0530, Srikar Dronamraju wrote:
> > +/* Should be called lock-less */
> > +static void put_uprobe(struct uprobe *uprobe)
> > +{
> > + if (atomic_dec_and_test(&uprobe->ref))
> > + kfree(uprobe);
> > +}
>
> Since this instantly frees the uprobe once ref hits 0, the
> atomic_inc_not_zero() in find_uprobe() doesn't really make sense does
> it?

Okay, I can move the atomic_inc_not_zero() in find_uprobe() to
atomic_inc().

Do you see any side-effects of using atomic_inc_not_zero?

--
Thanks and Regards
Srikar
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/