Re: [RFC] [PATCH 2.6.37-rc5-tip 4/20] 4: uprobes: Adding andremove a uprobe in a rb tree.

From: Srikar Dronamraju
Date: Wed Jan 26 2011 - 03:51:01 EST


> > + spin_lock_irqsave(&treelock, flags);
> > + while (*p) {
> > + parent = *p;
> > + u = rb_entry(parent, struct uprobe, rb_node);
> > + if (u->inode > uprobe->inode)
> > + p = &(*p)->rb_left;
> > + else if (u->inode < uprobe->inode)
> > + p = &(*p)->rb_right;
> > + else {
> > + if (u->offset > uprobe->offset)
> > + p = &(*p)->rb_left;
> > + else if (u->offset < uprobe->offset)
> > + p = &(*p)->rb_right;
> > + else {
> > + atomic_inc(&u->ref);
>
> If the lookup can find a 'dead' entry, then why can't we here?
>

If a new user of a uprobe comes up as when the last registered user was
removing the uprobe, we keep the uprobe entry till the new user
loses interest in that uprobe.

> > + goto unlock_return;
> > + }
> > + }
> > + }
> > + u = NULL;
> > + rb_link_node(&uprobe->rb_node, parent, p);
> > + rb_insert_color(&uprobe->rb_node, &uprobes_tree);
> > + atomic_set(&uprobe->ref, 2);
> > +
> > +unlock_return:
> > + spin_unlock_irqrestore(&treelock, flags);
> > + return u;
> > +}
>
> It would be nice if you could merge the find and 'acquire' thing, the
> lookup is basically the same in both cases.
>
> Also, I'm not quite sure on the name of that last function, its not a
> strict insert and what's the trailing _rb_node about? That lookup isn't
> called find_uprobe_rb_node() either is it?

Since we already have a install_uprobe, register_uprobe, I thought
insert_uprobe_rb_node would give context to that function that it was
only inserting an rb_node but not installing the actual breakpoint.
I am okay to rename it to insert_uprobe().
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/