Re: kswapd hung tasks in 2.6.38-rc1

From: Dave Hansen
Date: Mon Jan 31 2011 - 17:40:25 EST

On Mon, 2011-01-31 at 12:58 -0800, Dave Hansen wrote:
> On Thu, 2011-01-20 at 03:55 -0500, CAI Qian wrote:
> > When running LTP oom01 [1] testing, the allocation process stopped
> > processing right after starting to swap.
> I'm seeing the same stuff, but on -rc2. I thought it was
> transparent-hugepage-related, but I don't see much of a trace of it in
> the stack dumps.
> It happened to me as well around the time that things started to hit
> swap.

Still not a very good data point, but I ran a heavy swap load for an
hour or so without reproducing this. But, it happened again after I
enabled transparent huge pages. I managed to get a sysrq-t dump out of

khugepaged is one of the three running tasks. Note, I set both its
sleep timeouts to zero to stress it out a bit.

I'll keep trying to reproduce without THP.

-- Dave

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at