RE: [PATCH v2 02/13] da850: pruss platform specific additions.

From: TK, Pratheesh Gangadhar
Date: Mon Feb 28 2011 - 08:04:32 EST


Hi,

> -----Original Message-----
> From: davinci-linux-open-source-bounces@xxxxxxxxxxxxxxxxxxxx
> [mailto:davinci-linux-open-source-bounces@xxxxxxxxxxxxxxxxxxxx] On Behalf
> Of Subhasish Ghosh
> Sent: Friday, February 11, 2011 8:21 PM
> To: davinci-linux-open-source@xxxxxxxxxxxxxxxxxxxx
> Cc: sachi@xxxxxxxxxxxxxxxxxxxx; Russell King; Kevin Hilman; Subhasish
> Ghosh; open list; Watkins, Melissa; linux-arm-kernel@xxxxxxxxxxxxxxxxxxx
> Subject: [PATCH v2 02/13] da850: pruss platform specific additions.
>
> This patch adds the platform device and assignes the platform resources
> for the PRUSS mfd driver.
>
> Signed-off-by: Subhasish Ghosh <subhasish@xxxxxxxxxxxxxxxxxxxx>
> ---
> +struct platform_device da8xx_pruss_dev = {
Can you please rename this to da8xx_pruss_mfddev?
> + .name = "da8xx_pruss",
Can you please rename name string as pruss_mfd? This will help to
base my UIO patches on top of yours.
> + .id = -1,
> + .num_resources = ARRAY_SIZE(da8xx_pruss_resources),
> + .resource = da8xx_pruss_resources,
> +};
> +
> +int __init da8xx_register_pruss(struct da8xx_pruss_devices *pruss_device)
Please rename this to da8xx_register_pruss_mfd

Thanks,
Pratheesh
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/