Re: [PATCH 1/2] drivers/watchdog/s3c2410_wdt.c: Convert release_resourceto release_region/release_mem_region

From: Julia Lawall
Date: Fri Mar 18 2011 - 04:35:45 EST


On Fri, 18 Mar 2011, Wim Van Sebroeck wrote:

> Hi Julia, Kukjin Kim,
>
> > > Hmm...I think, 'res' is better for platform_get_resource().
> > > Do we _really_ need to change the name?...
> >
> > wdt_mem is a global variable. Is res a good name for a global variable?
> > One could say wdt_mem = res, if that seems better.
>
> If you look at the code then you have:
> static struct resource *wdt_mem;
> static struct resource *wdt_irq;
>
> and in the probe function you have:
> res = platform_get_resource(pdev, IORESOURCE_MEM, 0);
> ...
> wdt_mem = request_mem_region(res->start, size, pdev->name);
> ...
> wdt_irq = platform_get_resource(pdev, IORESOURCE_IRQ, 0);
>
> So doing Julia's:
> wdt_mem = platform_get_resource(pdev, IORESOURCE_MEM, 0);
> ...
> if (!request_mem_region(wdt_mem->start, size, pdev->name)) {
> ...
> wdt_irq = platform_get_resource(pdev, IORESOURCE_IRQ, 0)
>
> seems the best solution to me (since you then have both resources being polulated via platform_get_resource(pdev,... ).

Actually, I later realized that one can also use the result of
request_mem_region in place of res. Even though it is not the same
structure, it has the same start and end field information, which is the
only information that is used. But I haven't had a chance to send a patch
that follows that strategy. So if it is preferred to keep res, then that
can be done.

julia
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/