Re: [Patch] acpi: introduce "acpi_addr=" parameter for kdump
From: Len Brown
Date: Wed Mar 23 2011 - 00:28:54 EST
On Mon, 21 Mar 2011, Cong Wang wrote:
> ä 2011å03æ11æ 00:26, Randy Dunlap åé:
> > On Thu, 10 Mar 2011 22:10:43 +0800 Amerigo Wang wrote:
> > > + acpi_addr= [ACPI,EFI]
> > > + Pass the RSDP address to the kernel, mostly used
> > > + on machines running EFI runtime service to boot the
> > > + second kernel for kdump.
> > > +
> > I think that "acpi_addr" is a bit too generic. How about
> > acpi_rsdp or acpi_root instead?
> Yup, I agree "acpi_rsdp" is better.
This should also be [KEXEC], and the code should be #ifdef CONFIG_KEXEC
so that sane people can exclude it from their kernels.
Len Brown, Intel Open Source Technology Center