Re: [PATCH 1/3] Add a kstrtobool function matching semantics ofexisting in kernel equivalents.

From: Greg KH
Date: Wed Mar 23 2011 - 14:47:25 EST

On Wed, Mar 23, 2011 at 04:37:40PM +0000, Jonathan Cameron wrote:
> > Ok, perhaps the name might need to be changed a bit, but the idea is
> > still good to have. Please try again.
> >
> Any thoughts on what naming would work? Nothing immediately comes to mind
> which is why I ended up pinching the kstrto* naming...
> reallysloppy_strtobool?
> guessintent_strtobool?

usr_strtobool? I don't care :)

> or the old classic underscore prefix to 'encourage' people to check what it does
> before using it
> __strtobool?

Ick, no, that implies that no one outside of this file should call it.
Or it should be called with locks held or some such "special" thing.
Don't do that...


greg k-h
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at