Re: Corrupted files after suspend to disk

From: Rafael J. Wysocki
Date: Wed Mar 23 2011 - 16:36:40 EST

On Wednesday, March 23, 2011, richard -rw- weinberger wrote:
> Hi,
> I'm facing a very strange problem on my netbook (Lenovo Ideapad S10)
> running Linux
> After resuming from s2disk some files are corrupted.
> But when I reboot my netbook everything seems good again.
> When I saw the problem the first time the ls command segfaulted always.
> I did a reboot and it worked again.
> A few days later zypper crashed. After a reboot it worked again.
> And today ssh crashed. I looked a bit closer and saw it crashed
> somewhere within libcrypto.
> So I made copy libcrypto and rebooted.
> After the reboot ssh worked again but libcrypto and the copy of it hat
> a different sha1 sum!
> WTF?!
> Is this a known issue?


> dmesgs and config are attached.
> The used distribution is openSUSE 11.4 with suspend-0.80.20100129-7.1
> (default from suse).
> I'm using ext3 as root filesystem.
> What else do you need?

Whatever you can do to narrow down the problem. At the moment I only know
that it's there.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at