Re: [PATCH] linux/string.h: Introduce streq macro.

From: Thiago Farina
Date: Tue Apr 26 2011 - 15:47:37 EST


On Tue, Apr 26, 2011 at 4:45 PM, Joe Perches <joe@xxxxxxxxxxx> wrote:
> On Tue, 2011-04-26 at 15:37 -0400, Steven Rostedt wrote:
>> On Tue, 2011-04-26 at 16:21 -0300, Thiago Farina wrote:
>> > On Tue, Apr 26, 2011 at 4:20 PM, Alexey Dobriyan <adobriyan@xxxxxxxxx> wrote:
>> > > On Tue, Apr 26, 2011 at 03:17:48PM -0400, Steven Rostedt wrote:
>> > >> On Tue, 2011-04-26 at 22:05 +0300, Alexey Dobriyan wrote:
>> > >> > On Tue, Apr 26, 2011 at 03:49:49PM -0300, Thiago Farina wrote:
>> > >> > > + * streq - Are two strings equal?
>> > > The point is that function is trivial, and if someone doesn't
>> > > understand it, he should read some Kernighan and Ritchie first.
>> Replace it with something like:
>> Â Â Â * Use this: Â Â streq(a, b)
>> Â Â Â * instead of: Â strcmp(a, b) == 0 or !strcmp(a, b)
>> Â Â Â * This makes the code more readable and less error prone.
>
> I think it's not good to introduce another form.
> strcmp is the standard everyone understands.
>
> There are already about 2800 uses of strcmp()==0 and !strcmp
>
> $ grep -rP --include=*.[ch] "\bstrcmp.*==\s*0\b" * | wc -l
> 1143
> $ grep -rP --include=*.[ch] "\!\s*strcmp\s*\(" * Â| wc -l
> 1663
>
> Can you count how many misuses of strcmp have been
> corrected?

>ÂDo you plan to convert the existing 2800?

I'd work on this without any problem.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/