Re: [PATCH] staging: brcm80211: brcmfmac: Add and use dhd_dbg

From: Joe Perches
Date: Wed May 18 2011 - 20:32:49 EST

On Wed, 2011-05-18 at 15:45 -0700, Henry Ptasinski wrote:
> On 05/18/2011 11:23 AM, Joe Perches wrote:
> > All uses of DHD_<TYPE> macros are for debugging only.
> > Change the multiple uses of DHD_<TYPE>((...)) to dhd_dbg(TYPE, ...)
> > for a more consistent style.
> I generally like this approach, but in brcmsmac we've been switching to
> wiphy_err() and related instead. Any strong argument for one over the
> other?

These aren't described as errors but are debugging messages.

> > - DHD_TRACE(("%s: Enter\n", __func__));
> > + dhd_dbg(TRACE, "%s: Enter\n", __func__);
> I'd propose moving __func__ into the macro definition itself, which
> would help ensure consistency (and shorten all the debug lines a bit).

I think TRACE is unnecessary and can be eliminated
and replaced by the function tracer.

Not all uses use __func__.
I think __func__ unnecessary and it should be avoided.

Other than that, I've no objections.

> Also, perhaps rename to "brcm_dbg()", "bcm_dbg()" or something like that
> and move it into include/bcmutils.h, so brcmsmac can use it as well.

Your choice.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at