Re: [PATCH] Introduce ActivePid: in /proc/self/status (v2, wasVpid:)
From: Louis Rilling
Date: Thu Jun 16 2011 - 11:08:29 EST
On 16/06/11 16:51 +0200, Oleg Nesterov wrote:
> On 06/16, Louis Rilling wrote:
> > On 16/06/11 15:00 +0200, Greg Kurz wrote:
> > > peeking into pid->numbers.
> > It ends like open-coding an optimized version of task_pid_vnr(). If the
> > optimization is really important (I guess this depends on the depth of recursive
> > pid namespaces), it would be better to re-write task_pid_vnr().
> No, task_pid_vnr(p) is different, it should use the caller's namespace.
Damned, I read __task_pid_nr_ns() too quickly. Thanks for correcting me.
> Just in case, I agree there is no need to optimize this code. The simpler
> the better. I mentioned pid->numbers[pid->level] just to point that all
> we need is task_pid() itself, there are no subtle races which need the
Dr Louis Rilling Kerlabs
Skype: louis.rilling Batiment Germanium
Phone: (+33|0) 6 80 89 08 23 80 avenue des Buttes de Coesmes
http://www.kerlabs.com/ 35700 Rennes
Description: Digital signature