Re: [PATCH] gpio: gpio-ml-ioh: fix off-by-one for displayingvariable i in dev_err

From: Grant Likely
Date: Thu Jun 16 2011 - 15:45:20 EST


On Tue, Jun 14, 2011 at 07:12:57PM +0800, Axel Lin wrote:
> with the "for (; i != 0; i--)" sytax, i-- will be executed after the iteration.
> thus dev_err shows wrong i value.
> Switch to "while(--i >= 0)" which is better in readability.
>
> Signed-off-by: Axel Lin <axel.lin@xxxxxxxxx>

Merged, thanks.

g.

> ---
> drivers/gpio/gpio-ml-ioh.c | 2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/drivers/gpio/gpio-ml-ioh.c b/drivers/gpio/gpio-ml-ioh.c
> index 1bc621a..a9016f5 100644
> --- a/drivers/gpio/gpio-ml-ioh.c
> +++ b/drivers/gpio/gpio-ml-ioh.c
> @@ -233,7 +233,7 @@ static int __devinit ioh_gpio_probe(struct pci_dev *pdev,
> return 0;
>
> err_gpiochip_add:
> - for (; i != 0; i--) {
> + while (--i >= 0) {
> chip--;
> ret = gpiochip_remove(&chip->gpio);
> if (ret)
> --
> 1.7.4.1
>
>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/