On 06/20/2011 10:21 AM, Gleb Natapov wrote:Write it, handle me the patch, I'll include it and test it.On Sun, Jun 19, 2011 at 04:02:22PM +0300, Avi Kivity wrote:
> On 06/19/2011 03:59 PM, Gleb Natapov wrote:
> >On Sun, Jun 19, 2011 at 03:35:58PM +0300, Avi Kivity wrote:
> >> On 06/15/2011 12:09 PM, Gleb Natapov wrote:
> >> >>
> >> >> Actually, I'd expect most read/writes to benefit from caching,
> >> >> So why don't we just rename kvm_write_guest_cached() to
> >> >> kvm_write_guest(), and the few places - if any - that need to
> >> >> transversing of the gfn mappings, get renamed to
> >> >> kvm_write_guest_uncached ?
> >> >>
> >> >Good idea. I do not see any places where
> >> >needed from a brief look. Avi?
> >> >
> >> kvm_write_guest_cached() needs something to supply the cache, and
> >> needs recurring writes to the same location. Neither of these are
> >> common (for example, instruction emulation doesn't have either).
> >Correct. Missed that. So what about changing steal time to use
> Makes sense, definitely. Want to post read_guest_cached() as well?
Glauber can you write read_guest_cached() as part of your series (should
be trivial), or do you want me to do it? I do not have a code to test it
with though :)
(you can write it, and Glauber can include it in the series)