Re: ac97: quiet make W=1 noise by initializing all fields of snd_ac97_codec_id_vendors and snd_ac97_codec_ids.

From: Takashi Iwai
Date: Mon Jul 25 2011 - 06:54:39 EST


At Sun, 24 Jul 2011 11:40:56 +0200,
Lionel Debroux wrote:
>
> make W=1 bitterly complains about missing initializations in
> snd_ac97_codec_id_vendors and snd_ac97_codec_ids.
> Initialize the last field, to make the output of make W=1 more readable.
>
> Patch against current Linus tree.

If we change the whole table entries, it'd be better to use C99 style
init, e.g.

#define _CODEC(_id, _mask, _name) \
.id = _id, .mask = _mask, .name = _name

static const struct ac97_codec_id snd_ac97_codec_id_vendors[] = {
{ _CODEC(0x41445300, 0xffffff00, "Analog Devices"),},
...

static const struct ac97_codec_id snd_ac97_codec_ids[] = {
{ _CODEC(0x41445303, 0xffffffff, "AD1819"), .patch = patch_ad1819 },
...
{ _CODEC(0x53494c20, 0xffffffe0, "Si3036,8"), .patch = mpatch_si3036, \
.mpatch = mpatch_si3036, .flags = AC97_MODEM_PATCH },
...


thanks,

Takashi
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/