Re: [PATCH 04/13] mm: new shrinker API

From: Christoph Hellwig
Date: Wed Aug 24 2011 - 02:17:46 EST


On Tue, Aug 23, 2011 at 07:23:30PM +1000, Dave Chinner wrote:
> > It's much more than just a single callback these days.
> >
> > > + * @scan_objects will be made from the current reclaim context.
> > > */
> > > struct shrinker {
> > > int (*shrink)(struct shrinker *, struct shrink_control *sc);
> > > + long (*count_objects)(struct shrinker *, struct shrink_control *sc);
> > > + long (*scan_objects)(struct shrinker *, struct shrink_control *sc);
> >
> > Is shrink_object really such a good name for this method?
>
> Apart from the fact it is called "scan_objects", I'm open to more
> appropriate names. I called is "scan_objects" because of the fact we
> are asking to scan (rather than free) a specific number objects on
> the LRU, and it matches with the "sc->nr_to_scan" control field.

Shrink_objects actually was my suggestion - while we are asked to scan
the objects the scan really isn't the main purpose of it.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/