Re: [PATCH 20/20] Staging: hv: netvsc: Rename deviceInfo asdevice_info

From: Joe Perches
Date: Tue Sep 13 2011 - 14:10:34 EST


On Tue, 2011-09-13 at 10:59 -0700, K. Y. Srinivasan wrote:
> Rename deviceInfo as device_info.
[]
> diff --git a/drivers/staging/hv/rndis_filter.c b/drivers/staging/hv/rndis_filter.c
[]
> @@ -732,15 +732,15 @@ int rndis_filter_device_add(struct hv_device *dev,
[]
> dev_info(&dev->device, "Device MAC %pM link state %s",
> rndis_device->hw_mac_adr,
> - ((deviceInfo->link_state) ? ("down\n") : ("up\n")));
> + ((device_info->link_state) ? ("down\n") : ("up\n")));

Maybe get rid of the superfluous parentheses too?

dev_info(&dev->device, "Device MAC %pM link state %s\n",
rndis_device->hw_mac_adr,
device_info->link_state ? "down" : "up");

Also, struct rndis_device uses
u32 link_stat;
that is copied into struct netvsc_device_info
bool link_state;
could you please rationalize the names and types
of those 2 variables?


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/