Re: Samsung Series 9 seems to require acpi=nonvs to resume properly

From: Srivatsa S. Bhat
Date: Mon Oct 03 2011 - 03:07:30 EST

On 10/01/2011 01:39 AM, Zan Lynx wrote:
> On Thu, 2011-09-29 at 14:51 -0600, Zan Lynx wrote:
>> After being annoyed that the latest Fedora 2.6.40 (aka 3.0 something)
>> kernels would not suspend/resume on my laptop I followed a Ubuntu forum
>> suggestion to use acpi=nonvs. This worked, or at least it is working
>> today with Fedora 15's
>> The system is also booting via UEFI if that makes any difference.
>> I understand that there is a no-NVS blacklist in the kernel. Should the
>> Samsung Series 9 be added to this list? Or could it be a different
>> suspend/resume problem entirely?
> Please ignore this about nonvs. nonvs has nothing to do with the
> suspend/resume problem on this laptop.
> Instead it seems to involve reboots, which is crazy. From a cold
> power-on start, suspend resume will always fail. But if the laptop is
> rebooted first, suspend and resume appear to work. What the heck? I have
> no clue how to debug this.

Could you provide any error logs you found? That could give us a clue as to
what is going wrong...

> So now it appears that everything I ever tried to fix this only seemed
> to work because I rebooted after changing GRUB or module options.

Srivatsa S. Bhat <srivatsa.bhat@xxxxxxxxxxxxxxxxxx>
Linux Technology Center,
IBM India Systems and Technology Lab
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at