[PATCH] ath9k: rename ath9k_platform.h to ath_platform.h

From: Sangwook Lee
Date: Tue Nov 15 2011 - 06:25:56 EST


The patch series proposes to rename ath9k_platform.h to "ath_platform.h
This header file handles platform data used only for ath9k,
but it can used by ath6k as well. We can take "wl12xx.h" as
as a example. Please let us change this file name so that
other Atheors WLANs use this file for their own platform data

Signed-off-by: Sangwook Lee <sangwook.lee@xxxxxxxxxx>
---
arch/mips/ath79/dev-ar913x-wmac.c | 2 +-
drivers/net/wireless/ath/ath9k/ahb.c | 2 +-
drivers/net/wireless/ath/ath9k/init.c | 2 +-
drivers/net/wireless/ath/ath9k/pci.c | 2 +-
include/linux/{ath9k_platform.h => ath_platform.h} | 0
5 files changed, 4 insertions(+), 4 deletions(-)
rename include/linux/{ath9k_platform.h => ath_platform.h} (100%)

diff --git a/arch/mips/ath79/dev-ar913x-wmac.c b/arch/mips/ath79/dev-ar913x-wmac.c
index 48f425a..bc8869c 100644
--- a/arch/mips/ath79/dev-ar913x-wmac.c
+++ b/arch/mips/ath79/dev-ar913x-wmac.c
@@ -13,7 +13,7 @@
#include <linux/delay.h>
#include <linux/irq.h>
#include <linux/platform_device.h>
-#include <linux/ath9k_platform.h>
+#include <linux/ath_platform.h>

#include <asm/mach-ath79/ath79.h>
#include <asm/mach-ath79/ar71xx_regs.h>
diff --git a/drivers/net/wireless/ath/ath9k/ahb.c b/drivers/net/wireless/ath/ath9k/ahb.c
index 85a54cd..d84bee6 100644
--- a/drivers/net/wireless/ath/ath9k/ahb.c
+++ b/drivers/net/wireless/ath/ath9k/ahb.c
@@ -18,7 +18,7 @@

#include <linux/nl80211.h>
#include <linux/platform_device.h>
-#include <linux/ath9k_platform.h>
+#include <linux/ath_platform.h>
#include "ath9k.h"

static const struct platform_device_id ath9k_platform_id_table[] = {
diff --git a/drivers/net/wireless/ath/ath9k/init.c b/drivers/net/wireless/ath/ath9k/init.c
index af1b325..0c82aea 100644
--- a/drivers/net/wireless/ath/ath9k/init.c
+++ b/drivers/net/wireless/ath/ath9k/init.c
@@ -16,7 +16,7 @@

#include <linux/dma-mapping.h>
#include <linux/slab.h>
-#include <linux/ath9k_platform.h>
+#include <linux/ath_platform.h>

#include "ath9k.h"

diff --git a/drivers/net/wireless/ath/ath9k/pci.c b/drivers/net/wireless/ath/ath9k/pci.c
index edb0b4b..2f031b8 100644
--- a/drivers/net/wireless/ath/ath9k/pci.c
+++ b/drivers/net/wireless/ath/ath9k/pci.c
@@ -17,7 +17,7 @@
#include <linux/nl80211.h>
#include <linux/pci.h>
#include <linux/pci-aspm.h>
-#include <linux/ath9k_platform.h>
+#include <linux/ath_platform.h>
#include "ath9k.h"

static DEFINE_PCI_DEVICE_TABLE(ath_pci_id_table) = {
diff --git a/include/linux/ath9k_platform.h b/include/linux/ath_platform.h
similarity index 100%
rename from include/linux/ath9k_platform.h
rename to include/linux/ath_platform.h
--
1.7.4.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/