Re: [PATCH] gpio: add flags to export GPIOs when requesting

From: Denis Kuzmenko
Date: Tue Nov 15 2011 - 18:04:30 EST


Hi Wolfram,
On 11/16/2011 12:44 AM, Wolfram Sang wrote:
> Introduce new flags to automatically export GPIOs when using the convenience
> functions gpio_request_one() or gpio_request_array(). This eases support for
> custom boards where lots of GPIOs need to be exported for customer
> applications.

Adding GPIO maintainer Grant Likely to CC.

> +#define GPIOF_EXPORT (1 << 2)
> +#define GPIOF_EXPORT_CHANGEABLE (1 << 3)
> +#define GPIOF_EXPORT_DIR_FIXED (GPIOF_EXPORT)
> +#define GPIOF_EXPORT_DIR_CHANGEABLE (GPIOF_EXPORT | GPIOF_EXPORT_CHANGEABLE)

Maybe, it's better to write like this:

#define GPIOF_EXPORT (1 << 2)
#define GPIOF_EXPORT_DIR_CHANGEABLE (3 << 2)

So you don't need additional defines (GPIOF_EXPORT_DIR_FIXED and
GPIOF_EXPORT_DIR_CHANGEABLE). This will not brake your logic and improve
readability IMHO.

--
Best regards, Denis Kuzmenko.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/