[PATCH] mm/mempolicy.c: use enum value MPOL_REBIND_ONCE instead of0 in mpol_rebind_policy

From: Wang Sheng-Hui
Date: Wed Dec 14 2011 - 08:28:11 EST


We have enum definition in mempolicy.h: MPOL_REBIND_ONCE.
It should replace the magic number 0 for step comparison in
function mpol_rebind_policy.

Signed-off-by: Wang Sheng-Hui <shhuiw@xxxxxxxxx>
---
mm/mempolicy.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/mm/mempolicy.c b/mm/mempolicy.c
index 9c51f9f..ecdaa8d 100644
--- a/mm/mempolicy.c
+++ b/mm/mempolicy.c
@@ -390,7 +390,7 @@ static void mpol_rebind_policy(struct mempolicy *pol, const nodemask_t *newmask,
{
if (!pol)
return;
- if (!mpol_store_user_nodemask(pol) && step == 0 &&
+ if (!mpol_store_user_nodemask(pol) && step == MPOL_REBIND_ONCE &&
nodes_equal(pol->w.cpuset_mems_allowed, *newmask))
return;

--
1.7.1


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/