Re: [PATCH v6] kvm: make vcpu life cycle separated from kvm instance

From: Takuya Yoshikawa
Date: Wed Dec 28 2011 - 05:28:12 EST

(2011/12/28 15:54), Liu ping fan wrote:

You are introducing kvm_arch_vcpu_zap().

Then, apart from the "zap" naming issue I mentioned last time,
Yes, I will correct "zap", as you said, its meaning is quite different
from destroy. :-)

what about other architectures than x86?

Have not considered it in detail yet. At first step, I just want to
figure out the whole frame, then, I will push them on other arch.
Maybe you foresee some problem when extending this onto other arch,
please tell me, thanks ï-).

I do not mind if those are supported or not now.

But if not, you should write what is currently supported and what should
be done in the future.

Of course, you should at least make sure that other architectures will
not be broken by your patch.

diff --git a/include/linux/kvm_host.h b/include/linux/kvm_host.h
index 900c763..b88d418d 100644
--- a/include/linux/kvm_host.h
+++ b/include/linux/kvm_host.h
@@ -117,6 +117,7 @@ enum {

struct kvm_vcpu {
struct kvm *kvm;
+ struct list_head list;
struct preempt_notifier preempt_notifier;
@@ -251,12 +252,14 @@ struct kvm {
struct mm_struct *mm; /* userspace tied to this vm */
struct kvm_memslots *memslots;
struct srcu_struct srcu;
+ struct srcu_struct srcu_vcpus;

Another srcu. This alone is worth explaining in the changelog IMO.

Sorry, but why? I think it is just a srcu, and because it has
different aim and want a independent grace period, so not multiplex

I cannot say what MUST be explained in the changelog.
But many well known maintainers are telling the importance of changelog.

It is up to you, and KVM maintainers.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at