Re: [PATCH] staging: comedi: refactor ni_pcimio driver and use module_comedi_pci_driver

From: Ian Abbott
Date: Tue May 15 2012 - 11:55:03 EST


On 2012-05-15 16:41, H Hartley Sweeten wrote:
On Tuesday, May 15, 2012 4:29 AM, Ian Abbott wrote:
On 2012-05-12 00:51, H Hartley Sweeten wrote:
+static struct comedi_driver ni_pcimio_driver = {
+ .driver_name = "ni_pcimio",

The original used the DRV_NAME macro expanding to "ni_pcimio" here...

+static struct pci_driver ni_pcimio_pci_driver = {
+ .name = "ni_pcimio",

... which could also be used here.

(I realize this is a bit late as the patch is already committed!)

I noticed that. A couple of the comedi drivers do this but it's not consistent.

Personally I don't care for the use of the DRV_NAME (or DRIVER_NAME
or whatever someone wants to call it) usage. It doesn't same any code
space and always makes me have to do a second search to see what the
"name" actually is.

Regardsless, if you prefer this in the drivers please let me know. It
would be nice to have them somewhat consistent before the comedi
support leaves staging.

It doesn't really matter as long as it's consistent within the driver. I tend to use macros for literals used several times as it often allows mistakes to be caught at compile-time.

I think DRV_NAME is still used in the request_irq() call though.

--
-=( Ian Abbott @ MEV Ltd. E-mail: <abbotti@xxxxxxxxx> )=-
-=( Tel: +44 (0)161 477 1898 FAX: +44 (0)161 718 3587 )=-
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/