[PATCH 5/5] vmevent: Rename one-shot mode to edge trigger mode

From: Anton Vorontsov
Date: Fri Jun 01 2012 - 08:27:01 EST


VMEVENT_ATTR_STATE_ONE_SHOT is misleading name. That is effect as
edge trigger shot, not only once.

Suggested-by: KOSAKI Motohiro <kosaki.motohiro@xxxxxxxxx>
Suggested-by: Pekka Enberg <penberg@xxxxxxxxxx>
Signed-off-by: Anton Vorontsov <anton.vorontsov@xxxxxxxxxx>
---
include/linux/vmevent.h | 4 ++--
mm/vmevent.c | 4 ++--
2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/include/linux/vmevent.h b/include/linux/vmevent.h
index b8ec0ac..b1c4016 100644
--- a/include/linux/vmevent.h
+++ b/include/linux/vmevent.h
@@ -31,9 +31,9 @@ enum {
*/
VMEVENT_ATTR_STATE_VALUE_EQ = (1UL << 2),
/*
- * One-shot mode.
+ * Edge trigger mode.
*/
- VMEVENT_ATTR_STATE_ONE_SHOT = (1UL << 3),
+ VMEVENT_ATTR_STATE_EDGE_TRIGGER = (1UL << 3),

__VMEVENT_ATTR_STATE_INTERNAL = (1UL << 30) |
(1UL << 31),
diff --git a/mm/vmevent.c b/mm/vmevent.c
index e64a92d..46c1d18 100644
--- a/mm/vmevent.c
+++ b/mm/vmevent.c
@@ -104,7 +104,7 @@ static bool vmevent_match(struct vmevent_watch *watch)
continue;

if (attr_lt || attr_gt || attr_eq) {
- bool one_shot = state & VMEVENT_ATTR_STATE_ONE_SHOT;
+ bool edge = state & VMEVENT_ATTR_STATE_EDGE_TRIGGER;
u32 was_lt_mask = VMEVENT_ATTR_STATE_VALUE_WAS_LT;
u32 was_gt_mask = VMEVENT_ATTR_STATE_VALUE_WAS_GT;
u64 value = vmevent_sample_attr(watch, attr);
@@ -117,7 +117,7 @@ static bool vmevent_match(struct vmevent_watch *watch)
bool ret = false;

if (((attr_lt && lt) || (attr_gt && gt) ||
- (attr_eq && eq)) && !one_shot)
+ (attr_eq && eq)) && !edge)
return true;

if (attr_eq && eq && was_eq) {
--
1.7.9.2

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/