[RFC PATCHSET 0/3] tools lib traceevent: Generic error handling for pevent

From: Namhyung Kim
Date: Tue Jun 12 2012 - 03:45:46 EST


Hi,

This is a small patch series for preparation of the die removal.
I added some error code to be used for pevent_parse_event() and
_strerror function much like the perf target does.

I don't like the name 'pevent' but since it's a part of the API
so I used it for the name.

This can eliminate a few of die() and do_warning() but will lose
some details on the error message - i.e. event name. I couldn't
think of a way that doesn't lose such info after returning from
the function. But I guess we might get the info from the context.

Patch 01 is independent and can be applied separately.

Any comments are welcome.

Thanks,
Namhyung


Namhyung Kim (3):
tools lib traceevent: Do not link broken field arg for an old ftrace event
tools lib traceevent: Introduce pevent_errno
tools lib traceevent: Introduce pevent_strerror

tools/lib/traceevent/event-parse.c | 104 ++++++++++++++++++++++++++++--------
tools/lib/traceevent/event-parse.h | 28 +++++++++-
2 files changed, 107 insertions(+), 25 deletions(-)

--
1.7.10.2

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/