Re: [PATCH] remoteproc: adopt the driver core's alloc/add/del/putnaming

From: Stephen Boyd
Date: Wed Jul 04 2012 - 22:51:06 EST

On 7/4/2012 6:36 AM, Ohad Ben-Cohen wrote:
> To make remoteproc's API more intuitive for developers, we adopt
> the driver core's naming, i.e. alloc -> add -> del -> put. We'll also
> add register/unregister when their first user shows up.
> Otherwise - there's no functional change here.
> Suggested by Russell King <linux@xxxxxxxxxxxxxxxx>.
> Cc: Russell King <linux@xxxxxxxxxxxxxxxx>

Acked-by: Stephen Boyd <sboyd@xxxxxxxxxxxxxx>

> Cc: Fernando Guzman Lugo <fernando.lugo@xxxxxx>
> Cc: Sjur BrÃndeland <sjur.brandeland@xxxxxxxxxxxxxx>
> Signed-off-by: Ohad Ben-Cohen <ohad@xxxxxxxxxx>
> ---
Sent by an employee of the Qualcomm Innovation Center, Inc.
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at