Re: [PATCH] x86/mce: Need to let kill_proc() send signal to doomed process

From: Tony Luck
Date: Tue Jul 10 2012 - 13:12:15 EST


On Tue, Jul 10, 2012 at 8:44 AM, Borislav Petkov <bp@xxxxxxxxx> wrote:
> Acked-by: Borislav Petkov <borislav.petkov@xxxxxxx>

Thanks for the Ack.

+ doit = !!PageDirty(ppage) || !!(flags & MF_MUST_KILL);

Thinking about this some more, the "!!" are redundant
and are an impediment to readability. We started with
!!PageDirty(ppage) when we were passing an argument
directly to kill_procs() and wanted to make sure we had a
nice boolean value. But the result of the "||" is boolean,
so we don't need to double negate.

I'm going to change it to:
doit = PageDirty(ppage) || (flags & MF_MUST_KILL);

-Tony
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/