Re: [PATCH 2/3] iio: use IIO_CHAN_INFO_RAW rather than 0

From: Jonathan Cameron
Date: Mon Aug 27 2012 - 13:25:16 EST


On 08/16/2012 08:39 AM, Kim, Milo wrote:
> (a) For better readability, replace 0 with IIO_CHAN_INFO_RAW.
> (b) Make same line-format as other apis()
> : iio_read_channel_scale() and iio_read_channel_offset()
>
merged. Thanks.
> Signed-off-by: Milo(Woogyom) Kim <milo.kim@xxxxxx>
> ---
> drivers/iio/inkern.c | 6 ++++--
> 1 files changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/iio/inkern.c b/drivers/iio/inkern.c
> index bd09245..5103337 100644
> --- a/drivers/iio/inkern.c
> +++ b/drivers/iio/inkern.c
> @@ -239,8 +239,10 @@ int iio_read_channel_raw(struct iio_channel *chan, int *val)
> goto err_unlock;
> }
>
> - ret = chan->indio_dev->info->read_raw(chan->indio_dev, chan->channel,
> - val, &val2, 0);
> + ret = chan->indio_dev->info->read_raw(chan->indio_dev,
> + chan->channel,
> + val, &val2,
> + IIO_CHAN_INFO_RAW);
> err_unlock:
> mutex_unlock(&chan->indio_dev->info_exist_lock);
>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/