Re: [PATCH -v2 12/13] x86, mm: Use func pointer to table sizecalculation and mapping.

From: Yinghai Lu
Date: Mon Sep 03 2012 - 02:20:56 EST


On Sun, Sep 2, 2012 at 10:43 PM, Pekka Enberg <penberg@xxxxxxxxxx> wrote:
> On Sun, Sep 2, 2012 at 10:46 AM, Yinghai Lu <yinghai@xxxxxxxxxx> wrote:
>> +static void __init with_all_ram_ranges(
>> + void (*work_fn)(unsigned long, unsigned long, void *),
>> + void *data)
>
>> +static void __init size_work_fn(unsigned long start, unsigned long end, void *data)
>
>> +static void __init mapping_work_fn(unsigned long start, unsigned long end,
>> + void *data)
>
> So I passionately hate the naming convention. How about something
> similar to mm/pagewalk.c:
>
> s/with_all_ram_ranges/walk_ram_ranges/g

ok.

>
> s/size_work_fn/table_space_size/g
>
> s/mapping_work_fn/map_memory/g

I would prefer simple one size_work_fn, and mapping_working_fn.

Thanks

Yinghai
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/