[PATCH tip/core/rcu 0/7] CPU hotplug changes for 3.8

From: Paul E. McKenney
Date: Tue Oct 30 2012 - 12:55:36 EST


Hello!

This patch series provides further updates to RCU's interaction with
CPU hotplug. The individual patches are as follows:

1. Fix an obsolete comment describing ->onofflock.
2. Make rcutorture print the errno from cpu_down() failure if
the "verbose" module parameter is specified.
3. Make _cpu_down() use stop_cpus() instead of __stop_machine().
4. Rename ->onofflock to ->orphan_lock to correctly indicate this
lock's current scope.
5. Avoid counter wrap in synchronize_sched_expedited().
6. Move synchronize_sched_expedited() from global variables to
the rcu_state structure.
7. Instrument synchronize_rcu_expedited() for debugfs tracing.

Thanx, Paul

b/kernel/cpu.c | 9 ++-
b/kernel/rcutorture.c | 9 +++
b/kernel/rcutree.c | 4 -
b/kernel/rcutree.h | 7 +-
b/kernel/rcutree_plugin.h | 3 -
kernel/rcutree.c | 112 ++++++++++++++++++++++++++++++----------------
kernel/rcutree.h | 12 ++++
7 files changed, 108 insertions(+), 48 deletions(-)

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/