Re: [PATCH 1/8] staging: line6: wrap >80 char lines in capture.c

From: Dan Carpenter
Date: Thu Nov 15 2012 - 16:40:04 EST


On Thu, Nov 15, 2012 at 10:03:27PM +0100, Markus Grabner wrote:
> Am Mittwoch, 14. November 2012, 17:33:05 schrieb Dan Carpenter:
> > On Sun, Nov 11, 2012 at 01:24:39PM +0100, Stefan Hajnoczi wrote:
> > > Signed-off-by: Stefan Hajnoczi <stefanha@xxxxxxxxx>
> > > ---
> > >
> > > drivers/staging/line6/capture.c | 13 ++++++++-----
> > > 1 file changed, 8 insertions(+), 5 deletions(-)
> > >
> > > diff --git a/drivers/staging/line6/capture.c
> > > b/drivers/staging/line6/capture.c index c85c5b6..389c41f 100644
> > > --- a/drivers/staging/line6/capture.c
> > > +++ b/drivers/staging/line6/capture.c
> > > @@ -256,8 +256,8 @@ static void audio_in_callback(struct urb *urb)
> > >
> > > #ifdef CONFIG_LINE6_USB_IMPULSE_RESPONSE
> > >
> > > if (!(line6pcm->flags & LINE6_BITS_PCM_IMPULSE))
> > >
> > > #endif
> > >
> > > - if (test_bit(LINE6_INDEX_PCM_ALSA_CAPTURE_STREAM, &line6pcm-
> >flags)
> > > - && (fsize > 0))
> > > + if (test_bit(LINE6_INDEX_PCM_ALSA_CAPTURE_STREAM,
> >
> > The reason this is hitting the 80 character limit is because
> > "LINE6_INDEX_PCM_ALSA_CAPTURE_STREAM" is 35 characters long. It
> > isn't even clear from the name what it holds. It's just a very crap
> > name.
> Please refer to the file pcm.h for a detailed documentation of this and
> similar names (in fact, the documentation explains the LINE6_BIT_PCM_* names
> instead, but I bevlieve the correspondence is obvious). It's hard to define a
> shorter name which is at the same time descriptive, consistent, and not to be
> confused with related names.
>
> Should such documentation be moved to a separate file (e.g.,
> "Documentation/sound/alsa/line6usb.txt")?

The documentation is pretty good actually and it belongs where it
is. But 35 characters is just tooooooooooooooooooooooooooooooooooo
long.

To me the word "INDEX_" is confusing because what are we indexing?
In this context it means the the variable is a bit flag. That was
obvious because we were calling test_bit().

I think we could drop the PCM_ as well, because why do we need that?

We could change the LINE6 to L6.

if (test_bit(L6_ALSA_CAPTURE_STREAM, &line6pcm - flags)

It fits!

regards,
dan carpenter

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/