Re: [RFC] gpiolib: introduce descriptor-based GPIO interface

From: Linus Walleij
Date: Fri Dec 07 2012 - 03:24:00 EST


On Fri, Dec 7, 2012 at 3:06 AM, Alex Courbot <acourbot@xxxxxxxxxx> wrote:
> On Thursday 06 December 2012 22:42:59 Grant Likely wrote:
>> how about "gpio_chip_hwnum()" to somewhat match irqdomain convention?
>
> Sure, matching existing interfaces is better. "git grep hwnum" does not seem
> to reveal much related to irqdomain though?

I think Grant is referring to the similarity with hwirq. Check:
include/linux/irqdomain.h

For example GPIO drivers using irqdomain often look up the
trigging local GPIO pin offset from the irqdomain descriptor
passed with the interrupt like this:

static void foo_gpio_irq_unmask(struct irq_data *d)
int offset = d->hwirq;
(...)

Maybe "hwgpio" is an even better choice for the name of this.

Yours,
Linus Walleij
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/