RE: [v3 PATCH 05/12] spi/atmel_spi: update the dt support

From: Yang, Wenyou
Date: Mon Jan 07 2013 - 20:02:01 EST




> -----Original Message-----
> From: Joe Perches [mailto:joe@xxxxxxxxxxx]
> Sent: 2013年1月7日 10:06
> To: Yang, Wenyou
> Cc: linux-arm-kernel@xxxxxxxxxxxxxxxxxxx; linux-kernel@xxxxxxxxxxxxxxx; Ferre,
> Nicolas; plagnioj@xxxxxxxxxxxx; richard.genoud@xxxxxxxxx; Lin, JM
> Subject: Re: [v3 PATCH 05/12] spi/atmel_spi: update the dt support
>
> On Mon, 2013-01-07 at 09:50 +0800, Wenyou Yang wrote:
> > To meet the different spi IP version of atmel SoC,
> > add more compatible "atmel,at91rm9200-spi", "atmel,at91sam9260-spi"
> > "atmel,at91sam9g45-spi", "atmel,at91sam9x5-spi" with different
> > config and devtype.
>
> trivial comment:
>
> > diff --git a/drivers/spi/spi-atmel.c b/drivers/spi/spi-atmel.c
> []
> > @@ -230,11 +302,15 @@ struct atmel_spi_device {
> > * register, but I haven't checked that it exists on all chips, and
> > * this is cheaper anyway.
> > */
> > -static bool atmel_spi_is_v2(void)
> > +static bool atmel_spi_is_v2(struct atmel_spi *as)
>
> There's a comment that needs updating above this now
>
> > {
> > - return !cpu_is_at91rm9200();
> > + if (as->pdata->version == 2)
> > + return true;
> > + else
> > + return false;
>
> return as->pdata->version == 2;
>
> is rather more readable to me

Thanks a lot for quick feedback.
I will change it next version.
>

N?叉??y??b??千v??藓{.n???{?赙zXФ?塄}?财??j:+v???赙zZ+?zf"?????i????ア??璀??撷f?^j谦y??@A?囤?0鹅h??i