Re: [PATCH 02/17] mmzone: add various zone_*() helper functions.

From: Dave Hansen
Date: Tue Jan 15 2013 - 20:19:03 EST


On 01/15/2013 04:24 PM, Cody P Schafer wrote:
> +static inline bool zone_spans_pfn(const struct zone *zone, unsigned long pfn)
> +{
> + return zone->zone_start_pfn <= pfn && pfn < zone_end_pfn(zone);
> +}

This needs some parenthesis, just for readability. There's also no
crime in breaking it up to be multi-line if you want.

> +static inline bool zone_is_initialized(struct zone *zone)
> +{
> + return !!zone->wait_table;
> +}
> +
> +static inline bool zone_is_empty(struct zone *zone)
> +{
> + return zone->spanned_pages == 0;
> +}



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/