Re: [PATCH] mmc: dw_mmc: Add MSHC compatible for Exynos4412

From: Dongjin Kim
Date: Wed Jan 23 2013 - 22:01:33 EST


Hi Jaehoon,

Yes, completely agree with you but I wanted to keep "exynos5250_"
before Exynos4210's drv_data is sorted out. Anyway "exynos5_" would be
ok, I think.

Regards,
Dongjin.

On Thu, Jan 24, 2013 at 11:41 AM, Jaehoon Chung <jh80.chung@xxxxxxxxxxx> wrote:
> On 01/24/2013 12:24 AM, Dongjin Kim wrote:
>> This patch adds the compatible string for MSHC controller of Exynos4412, and
>> reuse the controller specific properties with Exynos5250 since those have same
>> features.
>>
>> Signed-off-by: Dongjin Kim <tobetter@xxxxxxxxx>
>> ---
>> drivers/mmc/host/dw_mmc-exynos.c | 2 ++
>> 1 file changed, 2 insertions(+)
>>
>> diff --git a/drivers/mmc/host/dw_mmc-exynos.c b/drivers/mmc/host/dw_mmc-exynos.c
>> index 0cb9bcb..4f7685f 100644
>> --- a/drivers/mmc/host/dw_mmc-exynos.c
>> +++ b/drivers/mmc/host/dw_mmc-exynos.c
>> @@ -204,6 +204,8 @@ static const struct dw_mci_drv_data exynos5250_drv_data = {
>> };
>>
>> static const struct of_device_id dw_mci_exynos_match[] = {
>> + { .compatible = "samsung,exynos4412-dw-mshc",
>> + .data = &exynos5250_drv_data, },
> If we can use the same drv_data, should be changed to more generic name, not "exynos5250_".
>
> Best Regards,
> Jaehoon Chung
>> { .compatible = "samsung,exynos5250-dw-mshc",
>> .data = &exynos5250_drv_data, },
>> {},
>>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/