Re: [PATCH 05/12] perf, x86: Support Haswell v4 LBR format

From: Stephane Eranian
Date: Mon Jan 28 2013 - 17:20:22 EST


On Mon, Jan 28, 2013 at 11:08 PM, Andi Kleen <andi@xxxxxxxxxxxxxx> wrote:
>> > - if (lbr_format == LBR_FORMAT_EIP_FLAGS) {
>> > + if (lbr_format == LBR_FORMAT_EIP_FLAGS ||
>> > + lbr_format == LBR_FORMAT_EIP_FLAGS2) {
>> > mis = !!(from & LBR_FROM_FLAG_MISPRED);
>> > pred = !mis;
>> > - from = (u64)((((s64)from) << 1) >> 1);
>> > + if (lbr_format == LBR_FORMAT_EIP_FLAGS)
>> > + from = (u64)((((s64)from) << 1) >> 1);
>> > + else if (lbr_format == LBR_FORMAT_EIP_FLAGS2) {
>> > + intx = !!(from & LBR_FROM_FLAG_INTX);
>> > + abort = !!(from & LBR_FROM_FLAG_ABORT);
>> > + from = (u64)((((s64)from) << 3) >> 3);
>> > + }
>> > }
>> >
>> Wouldn't all that be more readable with a switch-case, especially given
>> that lbr_format could be extended.
>
> The current version works for me.

I know it works. I am questioning the style: hard to read.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/