Re: [PATCH 01/13] workqueue: remove WORK_CPU_NONE

From: Lai Jiangshan
Date: Tue Feb 05 2013 - 07:04:18 EST


ä 2013/2/5 3:49, Tejun Heo åé:
Hello, Lai.

On Fri, Feb 01, 2013 at 02:41:24AM +0800, Lai Jiangshan wrote:
In __next_wq_cpu() for_each_*wq_cpu(), the name WORK_CPU_LAST
is proper than WORK_CPU_NONE, convert them to WORK_CPU_LAST.

WORK_CPU_NONE is not used any more, just remove it.
...
#define for_each_wq_cpu(cpu) \
for ((cpu) = __next_wq_cpu(-1, cpu_possible_mask, 3); \
- (cpu) < WORK_CPU_NONE; \
+ (cpu) < WORK_CPU_LAST; \
(cpu) = __next_wq_cpu((cpu), cpu_possible_mask, 3))

LAST implies that it's the last element of the range and thus that
it's an inclusive range. Maybe we should rename it to WORK_CPU_END?


You are right, WORK_CPU_END seems better.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/