Re: [PATCH] rtc: add devm_rtc_device_{register,unregister}()

From: 'Tejun Heo'
Date: Mon Feb 25 2013 - 18:33:55 EST

On Mon, Feb 25, 2013 at 02:29:57PM -0800, Andrew Morton wrote:
> > + * Managed rtc_device_register(). The rtc_device returned from this function
> > + * are automatically freed on driver detach. See rtc_device_register()
> > + * for more information.
> > + */
> I think the name is inappropriate. devm functions start with "devm"
> and rtc functions start with "rtc" and this code is a part of rtc core,
> not a part of devm core. Hence it should be something like
> "rtc_devm_device_register".

I think devm_rtc_ is better. All other devm interface functions put
devm_ prefix first and I think it's better to make devm_ more
pronounced as it denotes a somewhat subtle difference in behavior.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at