[PATCH v3 0/4] Cosmetic changes to the android binder proc release code

From: Mirsal Ennaime
Date: Tue Mar 12 2013 - 06:43:04 EST


Hello,

These are cleanup patches related to the binder_deferred_release function
in the android binder staging driver which improve readability while removing
checkpatch and compiler warnings.

drivers/staging/android/binder.c | 138 +++++++++++++++++-----------
1 file changed, 84 insertions(+), 54 deletions(-)

Changes from v1:

* squashed patches 3 and 4 together instead of introducing a warning
in patch 3 then fix it in patch 4. (Following Joe Perches' review)
* removed the extra nd_refs variable from patch 1 and fixed whitespace
in patch 2 (Following Dan Carpenter's reviews)
* renamed the new binder_node_release_deferred function to a shorter
binder_node_release as releasing a node will allways be deferred

Changes from v2

* kept arguments aligned with parentesis (Following
Arve HjÃnnevÃg's review)
* added a fourth patch which removes function names from string litterals
in favor __func__ (Following Dan Carpenter's review)
* improved commit log messages slightly

Please excuse my wasting of your time for such trivia.
I do want to get the basics of submitting patches right
before starting any heavier lifting.

Thank you for your time and sorry again for the noise,
Best regards,

--
mirsal

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/